Shadowsocks 一键安装脚本(四合一)

技术 69331 次围观 183 次吐槽

本脚本适用环境

系统支持:CentOS 6+,Debian 7+,Ubuntu 12+
内存要求:≥128M
日期  :2017 年 02 月 24 日

关于本脚本

1、一键安装 Shadowsocks-Python, ShadowsocksR, Shadowsocks-Go, Shadowsocks-libev 版(四选一)服务端;
2、各版本的启动脚本及配置文件名不再重合;
3、每次运行可安装一种版本;
4、支持以多次运行来安装多个版本,且各个版本可以共存(注意端口号需设成不同);
5、若已安装多个版本,则卸载时也需多次运行(每次卸载一种);
6、Shadowsocks-Python 和 ShadowsocksR 安装后不可同时启动(因为本质上都属 Python 版)。

友情提示:如果你有问题,请先阅读这篇《Shadowsocks Troubleshooting》之后再询问。

默认配置

服务器端口:自己设定(如不设定,默认为 8989)
密码:自己设定(如不设定,默认为 teddysun.com)
备注:脚本默认创建单用户配置文件,如需配置多用户,请手动修改相应的配置文件后重启即可。

客户端下载

常规版 Windows 客户端
https://github.com/shadowsocks/shadowsocks-windows/releases

ShadowsocksR 版 Windows 客户端
https://github.com/shadowsocksr/shadowsocksr-csharp/releases

使用方法

使用root用户登录,运行以下命令:

wget --no-check-certificate -O shadowsocks-all.sh https://raw.githubusercontent.com/teddysun/shadowsocks_install/master/shadowsocks-all.sh
chmod +x shadowsocks-all.sh
./shadowsocks-all.sh 2>&1 | tee shadowsocks-all.log

安装完成后,脚本提示如下

Congratulations, your_shadowsocks_version install completed!
Your Server IP        :your_server_ip
Your Server Port      :your_server_port
Your Password         :your_password
Your Encryption Method:aes-256-cfb

Welcome to visit:https://teddysun.com/486.html
Enjoy it!

卸载方法

若已安装多个版本,则卸载时也需多次运行(每次卸载一种)

使用root用户登录,运行以下命令:

./shadowsocks-all.sh uninstall

启动脚本

启动脚本后面的参数含义,从左至右依次为:启动,停止,重启,查看状态。

Shadowsocks-Python 版:
/etc/init.d/shadowsocks-python start | stop | restart | status

ShadowsocksR 版:
/etc/init.d/shadowsocks-r start | stop | restart | status

Shadowsocks-Go 版:
/etc/init.d/shadowsocks-go start | stop | restart | status

Shadowsocks-libev 版:
/etc/init.d/shadowsocks-libev start | stop | restart | status

各版本默认配置文件

Shadowsocks-Python 版:
/etc/shadowsocks-python/config.json

ShadowsocksR 版:
/etc/shadowsocks-r/config.json

Shadowsocks-Go 版:
/etc/shadowsocks-go/config.json

Shadowsocks-libev 版:
/etc/shadowsocks-libev/config.json

更新日志

2017 年 02 月 24 日:
1、恢复: 通过 Github API 自动获取 Shadowsocks-libev 的最新 release 版本的功能(v3.0.3)。
2017 年 02 月 13 日:
1、升级: Shadowsocks-libev 版到版本 3.0.2;
2、升级: Shadowsocks-go 版到版本 1.2.1(基于 Github 最新代码,用 go 1.8 编译完成的 x86 和 x86_64 二进制文件);
3、修复:在 Debian 7 下默认没有 libudns-dev 依赖包的问题。
2017 年 02 月 12 日:
1、升级: Shadowsocks-libev 版到版本 3.0.1。
2017 年 01 月 27 日:
1、升级: Shadowsocks-go 版到版本 1.2.1 (仅适用于 x86_64 系统)

更多单版本 Shadowsocks 服务端一键安装脚本

ShadowsocksR 版一键安装脚本(CentOS,Debian,Ubuntu)
CentOS 下 Shadowsocks-libev 一键安装脚本
Debian 下 Shadowsocks-libev 一键安装脚本
Shadowsocks-go 一键安装脚本(CentOS,Debian,Ubuntu)

注意:以上单版本不可与该四合一版本混用。

转载请注明:秋水逸冰 » Shadowsocks 一键安装脚本(四合一)

发表评论
取消评论
  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
表情

已有评论 (183)

  1. 请教下,如何控制客户端账户? 比如一个账户一台或则几台设备才能使用,设定流量 带宽啥的?
    mossad12小时前回复
  2. 你好,该更新了啊
    你好6天前回复
  3. [email protected]:~# wget --no-check-certificate -O shadowsocks-go.sh https://raw.githubusercontent.com/teddysun/shadowsocks_install/master/shadowsocks-go.sh --2017-03-22 22:56:40-- https://raw.githubusercontent.com/teddysun/shadowsocks_install/master/shadowsocks-go.sh 正在解析主机 raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.100.133 正在连接 raw.githubusercontent.com (raw.githubusercontent.com)|151.101.100.133|:443... 已连接。 无法建立 SSL 连接。 这个是什么问题啊?
    arvin1周前 (2017-03-22)回复
    • 这是你的 VPS 连不上 Github
      秋水逸冰1周前 (2017-03-22)回复
      • 手动执行过 yum -y install epel-release 依然提示 Loading mirror speeds from cached hostfile * base: mirror.scalabledns.com * elrepo: ftp.yz.yamagata-u.ac.jp * extras: mirror.scalabledns.com * updates: mirror.scalabledns.com Package asciidoc-8.6.8-5.el7.noarch already installed and latest version Nothing to do Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirror.scalabledns.com * elrepo: ftp.yz.yamagata-u.ac.jp * extras: mirror.scalabledns.com * updates: mirror.scalabledns.com No package udns-devel available. Error: Nothing to do Error: Failed to install udns-devel Please visit our website: https://teddysun.com/486.html for help
        • 先来确认一下 epel-release 是否真的已经安装上了。看看 /etc/yum.repos.d/epel.repo 这个文件有没有。 再手动安装一下 udns-devel 试试看。 yum -y install udns-devel
  4. 你好,现在你的SSR如果设置成CHACHA20的话就无法启动SSR,不知道是什么原因。
    SunZz1周前 (2017-03-22)回复
    • 我看了代码,里面是支持 chacha20 和 chacha20-ietf 的,你是不是配置文件没改对啊。
      秋水逸冰1周前 (2017-03-22)回复
  5. 您好!我使用Vultr的VPS,Ubuntu16.10 64位系统能够正常安装并启动ShadowSocks-Python,但是换了多个客户端都无法连接上。用Tcping测试到端口是打开的,但是ss的日志里面没有连接的信息,请问这个是什么问题,需要查看哪些日志?真心求教,谢谢!
    Chips1周前 (2017-03-21)回复
    • Ubuntu 的话,一般默认是没有打开防火墙的。那你检查一下看看是不是防火墙的原因。 通过以下命令检查一下进程和端口是否存在: netstat -nxltp
      秋水逸冰1周前 (2017-03-22)回复
  6. 搬瓦工KVM安装报错的,可使用单独包安装。
    我辈博客2周前 (2017-03-18)回复
  7. 其实我想问下,在Ubuntu14.04.3 LTS装好了,装的是ShadowsocksR版,还有个是shadowsocks.sh脚本的,完美安装完毕无错误,就是客户端连接没法上网,没法更新GFWlist。 端口除了默认我又改了8832之类的,不行,SSH是可以连接的。 求教,谢谢!
    后宫学长2周前 (2017-03-17)回复
    • 额...我换了Centos7之后再安装Shadowsocks-Python版,一次通过..... 莫非是Ubuntu端口没打开么.... 新人一枚。
      后宫学长2周前 (2017-03-19)回复
      • Ubuntu安装完毕以后,需要手动打开端口,执行apt install firewall,再执行firewall-cmd --add-port=8989/tcp,显示success即可。
        后宫学长2周前 (2017-03-19)回复
        • 其实安装完了,这条命令更好点。 sudo ufw allow 8989
          后宫学长2周前 (2017-03-19)回复
  8. 安装好后 手机连接成功,但提示无因特连接 不能上网,查了dns也是四个8的,请问是怎么回事呢?
    www.cnvpser.com2周前 (2017-03-17)回复
  9. bwg 的新的KVM机器,始终提示Error: Failed to install udns-devel
    shinkansen2周前 (2017-03-17)回复
  10. 已安装了,怎么更新呢
    Eric2周前 (2017-03-17)回复
  11. Error: Failed to install udns-devel
    662周前 (2017-03-16)回复
  12. 请问下,为什么EC2无法安装UDNS,使用了yum install -y epel-release这个命令也还是一样
    amazon2周前 (2017-03-13)回复
  13. 在安装R版的时候 报错了 提示如下 秋水大人,请看下应当 如何解决 dpkg: error processing package libhtml-parser-perl (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered while processing: libhtml-parser-perl E: Sub-process /usr/bin/dpkg returned an error code (1) Error: Failed to install gettext Please visit our website: https://teddysun.com/486.html for help ________________ [email protected]:~# apt-get install libhtml-parser-perl Reading package lists... Done Building dependency tree Reading state information... Done libhtml-parser-perl is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 1 not fully installed or removed. Need to get 0 B/109 kB of archives. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] Y dpkg: error processing package libhtml-parser-perl (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered while processing: libhtml-parser-perl E: Sub-process /usr/bin/dpkg returned an error code (1)
    tmpa2周前 (2017-03-13)回复
  14. SS/SSR支持UDP转发么?
    Lcuky3周前 (2017-03-11)回复
  15. 为什么现在这个包装个ss-libev要下载那么多东西啊(数G)。 要把debian7升级debian8说得过去。 我的vps模板已经debian8了还要下载那么多东西
    darkradx3周前 (2017-03-10)回复