CentOS下shadowsocks-libev一键安装脚本

技术 215125 次围观 772 次吐槽

本脚本适用环境:
系统支持:CentOS 32 或 64 位
内存要求:≥128M
日期:2016 年 09 月 23 日

关于本脚本:
一键安装 libev 版的 shadowsocks 最新版本。该版本的特点是内存占用小(600k左右),低 CPU 消耗,甚至可以安装在基于 OpenWRT 的路由器上。
友情提示:如果你有问题,请先参考这篇《Shadowsocks Troubleshooting》后再问。

默认配置:
服务器端口:自己设定(如不设定,默认为 8989)
客户端端口:1080
密码:自己设定(如不设定,默认为teddysun.com)

客户端下载:
https://github.com/shadowsocks/shadowsocks-windows/releases

使用方法:
使用root用户登录,运行以下命令:

wget --no-check-certificate https://raw.githubusercontent.com/teddysun/shadowsocks_install/master/shadowsocks-libev.sh
chmod +x shadowsocks-libev.sh
./shadowsocks-libev.sh 2>&1 | tee shadowsocks-libev.log

安装完成后,脚本提示如下:

Congratulations, Shadowsocks-libev install completed!
Your Server IP:your_server_ip
Your Server Port:your_server_port
Your Password:your_password
Your Local IP:127.0.0.1
Your Local Port:1080
Your Encryption Method:aes-256-cfb

Welcome to visit:https://teddysun.com/357.html
Enjoy it!

卸载方法:
使用 root 用户登录,运行以下命令:

./shadowsocks-libev.sh uninstall

其他事项:
客户端配置的参考链接:https://teddysun.com/339.html

安装完成后即已后台启动 Shadowsocks-libev ,运行:

/etc/init.d/shadowsocks status

可以查看进程是否启动。
本脚本安装完成后,会将 Shadowsocks-libev 加入开机自启动。

使用命令:
启动:/etc/init.d/shadowsocks start
停止:/etc/init.d/shadowsocks stop
重启:/etc/init.d/shadowsocks restart
查看状态:/etc/init.d/shadowsocks status

更多版本 Shadowsocks 安装:
ShadowsocksR 版一键安装脚本(CentOS,Debian,Ubuntu)
Shadowsocks Python 版一键安装脚本(CentOS,Debian,Ubuntu)
Debian 下 Shadowsocks-libev 一键安装脚本
Shadowsocks-go 一键安装脚本(CentOS,Debian,Ubuntu)

更新说明(2016 年 09 月 23 日):
1、修正:偶尔自动获取版本号失败的问题;
2、新增:自动判断如果 VPS 存在 IPv6 地址,则在配置文件里添加监听 IPv6 地址。
更新说明(2016 年 09 月 17 日):
1、重构代码,自动获取 Github 上最新版来安装,不再手动修改版本号;
2、自动检测本机是否已经安装,若已安装则正常退出(若要安装新版,则需先卸载);
3、改为下载 tar.gz 包来安装,不用依赖 unzip 命令。
更新说明(2016 年 09 月 12 日):
1、更新:升级版本到 2.5.2。
更新说明(2016 年 09 月 11 日):
1、更新:升级版本到 2.5.1。
更新说明(2016 年 08 月 29 日):
1、更新:升级版本到 2.5.0;
2、修正:由于安装时文件名的更新,卸载时文件名改为一致。
更新说明(2016 年 07 月 14 日):
1、更新:升级版本到 2.4.7。
更新说明(2016 年 07 月 05 日):
1、修正:新增的依赖 xmlto、asciidoc;
2、修正:由于安装时文件名的更新,卸载时文件名改为一致。
更新说明(2016 年 05 月 12 日):
1、新增:在 CentOS 7 下的防火墙规则设置。
更新说明(2015 年 08 月 01 日):
1、新增:自定义服务器端口功能(如不设定,默认为 8989)。
更新说明(2015 年 04 月 30 日):
1、修正:配置文件 /etc/shadowsocks-libev/config.json 同时启用 IPv4 与 IPv6 支持:

{
    "server":["[::0]","0.0.0.0"],
    "server_port":your_server_port,
    "local_address":"127.0.0.1",
    "local_port":1080,
    "password":"your_password",
    "timeout":600,
    "method":"aes-256-cfb"
}

2、Shadowsocks libev 版不能通过修改配置文件来多端口(只能开启多进程),如果你需要多端口请安装 Python 或 Go 版;

特别说明:
1、已安装旧版本的 shadowsocks 需要升级的话,需下载本脚本的最新版,运行卸载命令

./shadowsocks-libev.sh uninstall 

然后,下载最新版脚本即可安装最新版。

参考链接:
https://github.com/madeye/shadowsocks-libev

转载请注明:秋水逸冰 » CentOS下shadowsocks-libev一键安装脚本

发表评论
取消评论
  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
表情

已有评论 (772)

  1. 请问默认开启 UDP 吗??
    JANNCAI21小时前回复
  2. 能查看日志吗?
  3. 很棒! 就是这个页面不翻墙访问好像会被GFW拦了OTZ
  4. 博主你好~我无法连接到服务器,是因为我自己的原因吗? Resolving raw.githubusercontent.com... 151.101.100.133 Connecting to raw.githubusercontent.com|151.101.100.133|:443... 一直超时
    Vincent5天前回复
  5. checking for shl_load in -ldld... no checking for dlopen... no checking for dlopen in -ldl... yes checking whether a program can dlopen itself... yes checking whether a statically linked program can dlopen itself... yes checking whether stripping libraries is possible... yes checking if libtool supports shared libraries... yes checking whether to build shared libraries... no checking whether to build static libraries... yes checking for pcre-config... no checking for pcre location... not found configure: error: Cannot find pcre library. Configure --with-pcre=DIR make: *** No targets specified and no makefile found. Stop. Shadowsocks-libev install failed! Please visit https://teddysun.com/357.html and contact. 这是啥错误?我是删除旧版安装新版出错。
    miaosha6天前回复
  6. 默认开启 OTA 的?
    LisonFan1周前 (2016-09-22)回复
    • 默认没有开启OTA,需自己手动改一下配置文件 /etc/shadowsocks-libev/config.json 新增一个 "auth":true 然后再重启即可。
      秋水逸冰1周前 (2016-09-22)回复
      • 但是我没有动过这个文件也能使用 OTA,还有 log 在什么位置呢?
        LisonFan1周前 (2016-09-23)回复
      • 加一个 -A 就是强制启用 OTA,明白了。
        LisonFan1周前 (2016-09-23)回复
  7. firewall set start... port 8989 has been set up. firewall set completed... checking for gcc... no checking for cc... no checking for cl.exe... no configure: error: in `/root/shadowsocks-libev-2.5.2': configure: error: no acceptable C compiler found in $PATH See `config.log' for more details make: *** No targets specified and no makefile found. Stop. 查了网上说是缺少c编译器,然后我用yum install gcc安装了编译器,可是还是出这个提示,
    ravanelli2周前 (2016-09-19)回复
  8. 能搞个多IP设置的教程吗?很需要这个,谢谢.
    YCY2周前 (2016-09-19)回复
  9. make[2]: Leaving directory `/root/shadowsocks-libev-2.5.2/src' Making all in doc make[2]: Entering directory `/root/shadowsocks-libev-2.5.2/doc' GEN shadowsocks-libev.xml GEN shadowsocks-libev.8 /usr/bin/xmlto: line 576: 17649 Killed "$XSLTPROC_PATH" $XSLTOPTS -o "$XSLT_PROCESSED" "$STYLESHEET" "$INPUT_FILE" make[2]: *** [shadowsocks-libev.8] Error 1 rm shadowsocks-libev.xml make[2]: Leaving directory `/root/shadowsocks-libev-2.5.2/doc' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/root/shadowsocks-libev-2.5.2' make: *** [all] Error 2 秋水大大,您好,17号的版本我安装时报错,重装vps也是一样的
    jiange12362周前 (2016-09-18)回复
    • 这个的原因应该是内存过小,在 xmlto 编译的过程中进程被系统杀掉了导致失败。
      秋水逸冰2周前 (2016-09-19)回复
      • 那除了装旧版本还有其他办法吗?
        jiange12362周前 (2016-09-19)回复
        • 你的 VPS 内存过小,编译不了。 装 Go 版吧,这个无需编译,直接下载安装。
          秋水逸冰2周前 (2016-09-19)回复