Eclipse下搭建Python开发环境

技术 19763 次围观 16 次吐槽

Python

自从开始用Shadowsocks以来,研究了一下其源码,发现Python的简洁和强大,打算学习之。首先自然是搭建一下环境,用我所熟悉的Eclipse 再加上 Pydev即可。

一、下载Eclipse,官网地址:http://www.eclipse.org/downloads/
二、下载JDK,安装后配置一下环境变量。
官网地址:http://www.oracle.com/technetwork/java/javase/downloads/index.html 
三、下载和安装Python,这里选择2.X系列最新的2.7.6版本。3.X系列的Python语法上和旧版本稍许不一样。官网地址:http://www.python.org/downloads/
四、将Python开发工具Pydev集成到Eclipse,步骤如下:
打开Eclipse,Help,Install New Software…选择Add,
name填Pydev,location填http://pydev.org/updates。然后点ok,开始搜索,最后出现以下结果,选择第一个PyDev。

一路Next,进入安装路径选择界面,使用默认设置,然后 Finish。最后重启Eclipse即可。
五、配置解释器。
Pydev内可以配置的解释器有3种:IronPython、Jython、Python,这里默认用Python。
为了能在Eclipse中调试Python程序,配置解释器步骤如下:
在 Eclipse 菜单栏中,选择Window,Preferences,Pydev,Interpreter,Python Interpreter。然后New,Name填Python_interpreter,路径选择之前Python安装文件夹下的python.exe。

六、Hello,Python
在 Eclipse 菜单栏中,选择File,New,Pydev Project,Name处填HelloPython,一路Next。工程目录下,右键New,Pydev Module。
在编辑器里,输入一行:
print “Hello,Python!”
运行,这就开始python之旅吧。

转载请注明:秋水逸冰 » Eclipse下搭建Python开发环境

发表评论
取消评论
  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
表情

已有评论 (16)

  1. 建议冰哥再说一下那个py的字符编码的问题,因为来到你网站的基本都是中文系统的,所以默认中文编码,配置时候最好强制改成utf-8,以及编辑py代码的开头也要加入说明。
    romennts3年前 (2016-02-04)回复
  2. 在如今硬件的强大支撑下,Python确实是非常值得推广的语法
    wzc0x04年前 (2015-04-18)回复
  3. 最近在学 bash 脚本。。。还没学习 Python。。。。不知道能不能 直接 学习 Python。。。。。
    漠然4年前 (2015-03-02)回复
  4. 搭建这个感觉有点难
    站长工具4年前 (2015-02-03)回复
  5. 我使用lamp1.0[php5.2.17]在centos6.5x64上编译安装不成,请大神看看!
    skylei5年前 (2014-05-30)回复
    • lamp1.0版本已经不再支持。请下载最新版LAMP一键安装脚本进行安装。
      秋水逸冰5年前 (2014-05-30)回复
      • 可公司里面的服务环境是5.2.17其它的版本公司不让使用,或使用过后有兼容问题
        skylei5年前 (2014-05-31)回复
      • 你什么时候给调整调整可以使用行吗?或者更新一下
        skylei5年前 (2014-05-31)回复
        • 使用 PHP 版本 5.2.17,可是试一试军哥的 LNMP 一键包。
          秋水逸冰5年前 (2014-05-31)回复
          • 军哥的lnmp包可以,谢谢啊
            skylei5年前 (2014-06-06)回复
  6. python不错语法简单,运维都在使用这个,灵活比不上php
    skylei5年前 (2014-05-30)回复
  7. py语法太麻烦了。
    vfhky5年前 (2014-03-18)回复
    • 相比较而言,py语法还是很精简的了。
      秋水逸冰5年前 (2014-03-19)回复
  8. 赞一哈! 我一直用Netbeans作为IDE工具, netbeans也有python的插件。
    xjfengck5年前 (2014-03-17)回复
  9. 搭建这个不容易 都是英文
    屠龙5年前 (2014-03-10)回复