PHP加速缓存Zend Opcache

技术 4792 次围观 16 次吐槽

Zend Opcache

很多人都在问 PHP 加速缓存哪个好,毫无疑问 Zend Opcache 是首选。为什么?因为,这是官方出品的,在PHP5.5开始,已经随着PHP的源代码一起发布了。
在使用 LAMP 一键安装脚本后,如果你选的是 PHP 5.5 ,那么当 PHP 编译完成后,Zend Opcache 就已经存在了(/usr/local/php/lib/php/extensions/no-debug-non-zts-20121212/opcache.so )。
当然,如果选择了 PHP 5.3 或 PHP 5.4,也是可以安装 Zend Opcache 的,运行一键安装脚本 opcache.sh ,会自动安装 http://pecl.php.net/zendopcache 下的最新版。这货完全可以替代其他的缓存类工具,如 APC,eAccelerator,Xcache 等。

官方还没有 Zend Opcache 管理面板,虽然能在 phpinfo 里的 Zend OPcache下可以看到状态,但还是不够一目了然。目前有个开源的第三方管理面板可供选择,详见:这里。opcache.sh 脚本已经集成了该面板,只需在安装完成后,浏览器打开:http://yourwebsite/ocp.php 就能很直观的看到 Zend Opcache 的管理界面了。
我的 LAMP 一键安装脚本里,已经包含了可以探测 Zend Opcache 是否安装,并显示其版本号的探针文件 p.php 。
安装了 PHP 5.5 的截图如下:
Zend Opcache

安装了 PHP 5.4 的截图如下:
Zend Opcache

备注:Zend Guard Loader 目前还不支持 PHP 5.5 ,所以第一张截图里 Zend Guard Loader 是未安装状态。
关于 Zend Opcache 的介绍,已经无需我多说了,一搜一大把,反正优点多多,强烈建议使用。

转载请注明:秋水逸冰 » PHP加速缓存Zend Opcache

发表评论
取消评论
  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
表情

已有评论 (16)

  1. 过来学习一下
    kala4个月前 (2017-05-12)回复
  2. Opcache的提示非常有效。我需要加大它的可用内存(默认128M)和提高命中率应该怎么设置呢?
    Ave2年前 (2015-08-02)回复
    • 配置文件在这里 /usr/local/php/php.d/opcache.ini 改完重启 Apache 即可生效。
      秋水逸冰2年前 (2015-08-02)回复
  3. 很明显不支持php5.4.X
    猫叔2年前 (2015-04-10)回复
  4. 我的512内存的机器,装了Zend Opcache之后,mysql经常不能登录,不知道啥原因
    pirlo3年前 (2015-02-17)回复
  5. Edit php.ini zend_extension=/...full path.../opcache.so 当重启的时候,lnmp无任何报错,但是php程序已经不能运行了。
    大软3年前 (2015-01-17)回复
    • 你装的是 LNMP,而且我又不知道你装的 PHP 是哪个版本…… 如果你用我的 LAMP,那么可以直接运行 opcache.sh 安装 Zend Opcache 7.0.4,我刚刚升级了此脚本。
      秋水逸冰3年前 (2015-01-17)回复
  6. phpize 我的在/usr/local/php/bin/phpize ./configure --with-php-config=/usr/local/php/bin/php-config make make install
    大软3年前 (2015-01-17)回复
  7. LNMP已安装好了,我想安装最新版的 http://pecl.php.net/package/ZendOpcache wget -c http://pecl.php.net/get/zendopcache-7.0.4.tgz tar -zxvf zendopcache-7.0.4.tgz cd zendopcache-7.0.4 然后怎么做啊
    大软3年前 (2015-01-16)回复
  8. 这个是否可以和memcached共用?
    simon3年前 (2014-11-24)回复
  9. 您好,我用您的一键安装包11月14日版,选择了PHP 5.5.19。装完之后探针文件里Zend OPache是打叉的。但是opcache.so的却是存在的,请问要如何启用?
    Seymour LIU3年前 (2014-11-15)回复
    • 运行脚本 opcache.sh 后即可。
      秋水逸冰3年前 (2014-11-16)回复
      • 嗯,试过了,果然可以了。非常感谢! 另:Zend OPache启用后,还需要启用ionCube Loader么?
        Seymour LIU3年前 (2014-11-16)回复
        • 这个看你是否需要了,不过安装了也好
          秋水逸冰3年前 (2014-11-17)回复