Shadowsocks 一键安装脚本(四合一)

技术 秋水逸冰 1959768 次围观 1361 次吐槽

本脚本适用环境

系统支持:CentOS 6+,Debian 7+,Ubuntu 12+
内存要求:≥128M
日期  :2019 年 01 月 11 日

关于本脚本

1、一键安装 Shadowsocks-Python, ShadowsocksR, Shadowsocks-Go, Shadowsocks-libev 版(四选一)服务端;
2、各版本的启动脚本及配置文件名不再重合;
3、每次运行可安装一种版本;
4、支持以多次运行来安装多个版本,且各个版本可以共存(注意端口号需设成不同);
5、若已安装多个版本,则卸载时也需多次运行(每次卸载一种);

友情提示:如果你有问题,请先阅读这篇《Shadowsocks Troubleshooting》之后再询问。

默认配置

服务器端口:自己设定(如不设定,默认从 9000-19999 之间随机生成)
密码:自己设定(如不设定,默认为 teddysun.com)
加密方式:自己设定(如不设定,Python 和 libev 版默认为 aes-256-gcm,R 和 Go 版默认为 aes-256-cfb)
协议(protocol):自己设定(如不设定,默认为 origin)(仅限 ShadowsocksR 版)
混淆(obfs):自己设定(如不设定,默认为 plain)(仅限 ShadowsocksR 版)
备注:脚本默认创建单用户配置文件,如需配置多用户,请手动修改相应的配置文件后重启即可。

客户端下载

常规版 Windows 客户端
https://github.com/shadowsocks/shadowsocks-windows/releases

ShadowsocksR 版 Windows 客户端
https://github.com/shadowsocksrr/shadowsocksr-csharp/releases

使用方法

使用root用户登录,运行以下命令:

wget --no-check-certificate -O shadowsocks-all.sh https://raw.githubusercontent.com/teddysun/shadowsocks_install/master/shadowsocks-all.sh
chmod +x shadowsocks-all.sh
./shadowsocks-all.sh 2>&1 | tee shadowsocks-all.log

安装完成后,脚本提示如下

Congratulations, your_shadowsocks_version install completed!
Your Server IP        :your_server_ip
Your Server Port      :your_server_port
Your Password         :your_password
Your Encryption Method:your_encryption_method

Your QR Code: (For Shadowsocks Windows, OSX, Android and iOS clients)
 ss://your_encryption_method:[email protected]_server_ip:your_server_port
Your QR Code has been saved as a PNG file path:
 your_path.png

Welcome to visit:https://teddysun.com/486.html
Enjoy it!

卸载方法

若已安装多个版本,则卸载时也需多次运行(每次卸载一种)

使用root用户登录,运行以下命令:

./shadowsocks-all.sh uninstall

启动脚本

启动脚本后面的参数含义,从左至右依次为:启动,停止,重启,查看状态。

Shadowsocks-Python 版:
/etc/init.d/shadowsocks-python start | stop | restart | status

ShadowsocksR 版:
/etc/init.d/shadowsocks-r start | stop | restart | status

Shadowsocks-Go 版:
/etc/init.d/shadowsocks-go start | stop | restart | status

Shadowsocks-libev 版:
/etc/init.d/shadowsocks-libev start | stop | restart | status

各版本默认配置文件

Shadowsocks-Python 版:
/etc/shadowsocks-python/config.json

ShadowsocksR 版:
/etc/shadowsocks-r/config.json

Shadowsocks-Go 版:
/etc/shadowsocks-go/config.json

Shadowsocks-libev 版:
/etc/shadowsocks-libev/config.json

更新日志

2019 年 01 月 11 日:
1、升级:libsodium 到最新版本 1.0.17;
2、升级:mbedtls 到最新版本 2.16.0;

2018 年 11 月 05 日:
1、升级:使用 Github 上最新代码编译出 Go 版二进制可执行文件,版本号 1.2.2。

2018 年 06 月 01 日:
1、修正:在启用了插件 simple-obfs 的情况下,libev 版启动失败的问题;
2、修正:在使用 /etc/init.d/shadowsocks-libev restart 命令重启 libev 版服务端时,偶尔出现的 “bind: Address already in use” 问题;
3、修正:移除 libev 版配置文件中的 local_address 字段;
4、修改:不再默认使用 root 用户启动,改为使用 nobody 用户启动 libev 版服务端 ss-server;
5、升级:mbedtls 到版本 2.9.0;
6、修改:libev 版启动脚本中的 -u 参数(即同时启用 TCP 和 UDP 模式),改到配置文件里配置为 “mode”: “tcp_and_udp”;
7、修改:libev 版配置文件的内置 NameServers 为 8.8.8.8,默认是从 /etc/resolv.conf 中取得。

2018 年 02 月 07 日:
1、修改:将默认端口从 8989 改为从 9000-19999 之间随机生成。

2018 年 02 月 06 日:
1、修改:ShadowsocksR 版为 ShadowsocksRR 最新版;
2、新增:ShadowsocksR 版的协议(protocol)增加了 4 个,分别为:

auth_chain_c
auth_chain_d
auth_chain_e
auth_chain_f

2017 年 12 月 29 日:
1、升级:libsodium 到 1.0.16。

2017 年 11 月 25 日:
1、如果 Linux 内核版本大于 3.7.0,则配置文件默认支持 TCP fast open;
2、新增:libev 版启动时支持 verbose mode,也就是默认写 log 到 /var/log/messages 方便查看。

2017 年 11 月 12 日:
1、新增生成 ss:// 或 ssr:// 链接,以及其二维码图片。
※ 脚本会根据当前安装的版本以及输入的各项配置,自动生成 ss:// 或 ssr:// 的链接并在安装成功后显示,直接复制即可被客户端识别。同时生成其二维码图片,并保存在当前目录下,下载后用看图软件打开,也能被客户端识别。

复制二维码链接后 Shadowsocks 客户端识别示例:

复制二维码链接后 ShadowsocksR 客户端识别示例:

二维码(QR Code)参考链接:
https://github.com/shadowsocks/shadowsocks/wiki/Generate-QR-Code-for-Android-or-iOS-Clients
https://github.com/shadowsocksr-backup/shadowsocks-rss/wiki/SSR-QRcode-scheme

2017 年 10 月 22 日:
1、升级:libsodium 到 1.0.15。

2017 年 10 月 14 日:
1、新增:在安装 Shadowsocks-libev 版时可选安装 simple-obfs 服务端。
※ 脚本通过判断 autoconf 版本是否大于或等于 2.67 来一键安装 simple-obfs 服务端。并且,支持在安装过程中选择 obfs 为 http 或 tls。
※ 使用方法参考:https://teddysun.com/511.html

2017 年 09 月 16 日:
1、修正:Shadowsocks-libev 版 v3.1.0 使用 libc-ares 替换 libudns 依赖包,解决了依赖问题;
2、升级:mbedtls 到版本 2.6.0。

2017 年 07 月 27 日:
1、新增:ShadowsocksR 版可选协议(protocol)auth_chain_b 。使用该协议需更新到最新(4.7.0) ShadowsocksR 版客户端
2、修改:更新 ShadowsocksR 源码下载地址。

2017 年 07 月 23 日:
1、修正:卸载时可自行选择某个版本卸载,若该版本不存在则报错退出。

2017 年 07 月 22 日:
1、修正:默认加密方式从 aes-256-cfb 改为 aes-256-gcm(Python 和 libev 版);
2、新增:安装时可选 16 种加密方式的其中之一(Python 和 libev 版)。如下所示:

aes-256-gcm
aes-192-gcm
aes-128-gcm
aes-256-ctr
aes-192-ctr
aes-128-ctr
aes-256-cfb
aes-192-cfb
aes-128-cfb
camellia-128-cfb
camellia-192-cfb
camellia-256-cfb
chacha20-ietf-poly1305
chacha20-ietf
chacha20
rc4-md5

3、新增:安装时可选 9 种加密方式的其中之一(Go 版)。如下所示:

aes-256-cfb
aes-192-cfb
aes-128-cfb
aes-256-ctr
aes-192-ctr
aes-128-ctr
chacha20-ietf
chacha20
rc4-md5

4、新增:安装时可选 15 种加密方式的其中之一(none 是不加密,ShadowsocksR 版)。如下所示:

none
aes-256-cfb
aes-192-cfb
aes-128-cfb
aes-256-cfb8
aes-192-cfb8
aes-128-cfb8
aes-256-ctr
aes-192-ctr
aes-128-ctr
chacha20-ietf
chacha20
salsa20
xchacha20
xsalsa20
rc4-md5

5、新增:安装时可选 7 种协议(protocol)的其中之一(仅限 ShadowsocksR 版)。如下所示:

origin
verify_deflate
auth_sha1_v4
auth_sha1_v4_compatible
auth_aes128_md5
auth_aes128_sha1
auth_chain_a
auth_chain_b

6、新增:安装时可选 9 种混淆(obfs)的其中之一(仅限 ShadowsocksR 版)。如下所示:

plain
http_simple
http_simple_compatible
http_post
http_post_compatible
tls1.2_ticket_auth
tls1.2_ticket_auth_compatible
tls1.2_ticket_fastauth
tls1.2_ticket_fastauth_compatible

2017 年 02 月 24 日:
1、恢复: 通过 Github API 自动获取 Shadowsocks-libev 的最新 release 版本的功能(v3.0.3)。

2017 年 02 月 13 日:
1、升级: Shadowsocks-libev 版到版本 3.0.2;
2、升级: Shadowsocks-go 版到版本 1.2.1(基于 Github 最新代码,用 go 1.8 编译完成的 x86 和 x86_64 二进制文件);
3、修复:在 Debian 7 下默认没有 libudns-dev 依赖包的问题。

2017 年 02 月 12 日:
1、升级: Shadowsocks-libev 版到版本 3.0.1。

2017 年 01 月 27 日:
1、升级: Shadowsocks-go 版到版本 1.2.1 (仅适用于 x86_64 系统)

更多单版本 Shadowsocks 服务端一键安装脚本

Shadowsocks Python 版一键安装脚本(CentOS,Debian,Ubuntu)
ShadowsocksR 版一键安装脚本(CentOS,Debian,Ubuntu)
CentOS 下 Shadowsocks-libev 一键安装脚本
Debian 下 Shadowsocks-libev 一键安装脚本
Shadowsocks-go 一键安装脚本(CentOS,Debian,Ubuntu)

注意:以上单版本不可与该四合一版本混用。

转载请注明:秋水逸冰 » Shadowsocks 一键安装脚本(四合一)

发表我的评论
取消评论

请输入正确答案后提交评论 *

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

网友最新评论 (1361)

  1. 已加载插件:fastestmirror 设置安装进程 Loading mirror speeds from cached hostfile No package epel-release available. 错误:无须任何处理 Error: Failed to install epel-release Please visit our website: https://teddysun.com/486.html for help 所有的脚本都报这个错误,请问如何解决呢?
    Chauncey096年前 (2017-02-13)回复
    • 请检查你的 repo 配置,epel-release 是自带的依赖包。
      秋水逸冰6年前 (2017-02-13)回复
  2. 以前在用libev版 看到更新卸载重装之后 失败了 E: Unable to locate package libudns-dev Error: Failed to install libudns-dev Please visit our website: https://teddysun.com/486.html for help
    1Q946年前 (2017-02-13)回复
    • 针对 Debian 7 下没有 libudns-dev 依赖包的问题,已经在 2 月 13 日版的脚本里修复了。
      秋水逸冰6年前 (2017-02-13)回复
    • 关于这个问题 E: Unable to locate package libudns-dev Error: Failed to install libudns-dev Please visit our website: https://teddysun.com/486.html for help 我找了一个方法 在这个网站上下载离线安装包 https://centos.pkgs.org/7/epel-x86_64/udns-0.4-3.el7.x86_64.rpm.html 需要注意的是,安装这个包需要几个其他的依赖包,在这网页上有一个 Requires 选项卡,打开它会展示需要的依赖包,下载以后安装,再重装一次就好了
      brady5年前 (2017-06-23)回复
  3. 大大你好,使用最新脚本安装ss-libev后,出现:/usr/local/bin/ss-server: error while loading shared libraries: libmbedcrypto.so.0: cannot open shared object file: No such file or directory 根据https://github.com/shadowsocks/shadowsocks-libev/issues/1197里所说,需要echo /usr/local/lib > /etc/ld.so.conf.d/usr_local_lib.conf ldconfig, 输入命令后可以成功运行,不知道大大是否据此修改脚本?
    刘皓言6年前 (2017-02-12)回复
    • 安装完成后,应该会有这样的一个文件:/etc/ld.so.conf.d/local.conf,内容就是:/usr/local/lib 改了一下脚本逻辑,默认生成该文件了。
      秋水逸冰6年前 (2017-02-12)回复
  4. 安装成功,但是显示无互联网连接,出错信息:unable to resolve host "www.google.com":no address associated with hostname。这是vps哪里没设置好吗?之前安装之后正常使用,然后就突然这样了,再次安装还是这个问题,请指教,谢谢!
    有意思6年前 (2017-02-12)回复
  5. E: Package 'build-essential' has no installation candidate Error: Failed to install build-essential Please visit our website: https://teddysun.com/486.html for help
    wml00736年前 (2017-02-10)回复
  6. 输入/etc/shadowsocks-r/config.json 不显示配置文件 输入vi /etc/shadowsocks-r/config.json 显示的配置文件无法修改是怎么回事
    1236年前 (2017-02-09)回复
  7. 是否有开启服务端的日志记录的选项?记得之前好像在哪里见过这方面的提示,但一时想不起来。在博主 文章里Ctrl+F 搜索 日志 和 log 也没找到到相关的说明。
    wkl176年前 (2017-02-04)回复
    • Shadowsocks Python 版默认是开启日志的。 其日志位于 /var/log/shadowsocks.log
      秋水逸冰6年前 (2017-02-06)回复
  8. Error: Failed to install asciidoc 系统 centos 7 64位 Error: Nothing to do Error: Failed to install asciidoc Please visit our website: https://teddysun.com/486.html for help [[email protected] xxx-user]# [[email protected] xxx-user]# asciidoc Man page: asciidoc --help manpage Syntax: asciidoc --help syntax [[email protected] xxx-user]# 请问下一下这是怎么回事,谢谢,
    whywei6年前 (2017-02-04)回复
    • 应该是在 yum 安装依赖包 asciidoc 时出错导致的问题。 请试着手动安装 asciidoc 然后重新运行脚本看看。
      秋水逸冰6年前 (2017-02-06)回复
  9. 搬瓦工的主机,安装的centos 7 x64系统,安装此脚本第4个shadowsocks-libv,一切正常,然后退出ssh,再用ssh连接时无法连接主机,重装系统后可正常ssh主机,请方便的话查查是哪儿的问题,谢谢!
    hello6年前 (2017-01-31)回复
    • 很可能与iptables 规则有关。
      scsc5年前 (2017-08-20)回复
  10. 2017-01-28 15:27:12 (819 KB/s) - 'shadowsocks-libev-2.6.3.tar.gz' saved [242307/242307] shadowsocks-libev [found] ./shadowsocks-all.sh: line 574: ./configure: No such file or directory Shadowsocks-libev install failed. Please email to Teddysun and contact. libev版本重装失败......
    aowu6年前 (2017-01-28)回复
    • 发现是旧脚本没清除的问题,已解决
      aowu6年前 (2017-01-30)回复
  11. ./shadowsocks-libev.sh: line 333: ./configure: No such file or directory make: *** No targets specified and no makefile found. Stop. 安装时报错,看了下解压目录没有configure只有configure.ac
    yanglc6年前 (2017-01-26)回复
  12. 请问使用您的一键脚本之后,如果 ShadowsocksR Shadowsocks-Python Shadowsocks-Go Shadowsocks-libev 有版本更新,如何自行更新自己的服务端版本?
    jmyz_04556年前 (2017-01-25)回复
    • 同问一下,是否可以在脚本内增加更新功能?
      xoo6年前 (2017-02-11)回复
      • 一般不这么干,因为 Shadowsocks 的安装方式,编译方式甚至使用参数随时在变化,脚本也要跟着变化才行。
        秋水逸冰6年前 (2017-02-12)回复
  13. 秋大你好,非常感谢您能编写并开源这么方便的脚本,但是我在使用过程中遇到了点小问题想请教您一下: 我的VPS是vultr 5$/mo 的那个,部署过ss后基本可以跑满联通的百兆,之后又部署了LNMP并放了一个个人主页,基本没啥访问量,ss连接数也能保持在5个以内,但是ss的速度却大不如安装nginx之前的了(youtube看720P都特别卡),按道理来讲这个vps的性能同时运行ss+nginx不成问题啊?为什么会出现这种情况呢??
    Re_keto6年前 (2017-01-24)回复
  14. daemon.py:75 already started at pid 587 哥,这哥问题怎么解决呢,安装好SSR后,导出配置文件,编辑完重新上传后重启时无法启动,提示这个错误。
    Jaen6年前 (2017-01-24)回复
    • 已经解决无法启动的问题,不过可能是配置有问题,居然爬不上去。
      Jaen6年前 (2017-01-24)回复
  15. 楼主,您好,按照您的教程,我已经安装好了SSR,但是SSR只要加了混淆就无法上网,折腾了一整天都没有效果。请问我是哪里设置错了吗?
    crazyboy6年前 (2017-01-23)回复
    • 秋大,安装了ssr客户端,但只要加上混淆就不能翻了,应该是我设置的不对,问一下设置混淆出了在ssr的windows客户端设置,还需要其他的操作吗?
      clark5年前 (2017-03-17)回复